DLL's missing and 'System.IO.FileNotFoundException'

z94joma

New member
Joined
Jun 4, 2004
Messages
1
Programming Experience
3-5
Hi!

I have just run into a great urgent problem with my VB.Net application. I have no idea what happend and why it happend. Here goes:

For almost 2 months now I have been developing a VB.Net Window.Forms application doing a lot of stuff with Datasets and a DB an so on. Every thing has worked smoothly and I have not been running into any great problems until now.

Everything worked as normal until 3-4 days ago. I was able to compile a standalone .EXE of my program and make an installpackage of it. This was runnable on my and other computers when installed from my package. Suddenly I got this errormessage and I can't understand what and why it happend.

An unhandled exception of type 'System.IO.FileNotFoundException' occurred in STS Manager.exe
Additional information: File or assembly name AxInterop.MSChart20Lib, or one of its dependencies, was not found.

Note that this has been working great just a few days earlier.

I can still run my program in Visual Studio in both Debug and Release mode. The problem is that now I need to put some DLL's in my executables folder to get it to work. Why? This worked before without having to copy some DLL's to my executables folder before.

AxInterop.MSChart20Lib.dll
Interop.MSChart20Lib.dll
MSDATASRC.dll
stdole.dll

And if I add the DLL's above it get past that problem then the next problem occurs.

An unhandled exception of type 'System.InvalidOperationException' occurred in system.dll
Additional information: The key 'StatusBar1.ShowPanels' does not exist in the appSettings configuration section.

System.dll? It seems if my whole configuration has gotten mucked up?

I have tried with uninstalling Visual Studio .Net and reinstalling it again without any luck.

What am I doing wrong here? It worked like a charm a few days ago.

What I was doing when the problem occured was that I was trying to send a flag with the start of my program like e:\test.exe -f "http://www.test.com

Please help me sort out this problem. I have googled around a lot without luck. Only a few threads over the whole Internet has accessed this problem but no solution to it.

I have files under sourcecontrol but even if I back to a working spot I get this problem. Visual Studio or .Net configuration of where to find DLL's?

Looking forward to replies...

Best Regards

Magnus Svedberg
 

suddenelfilio

Well-known member
Joined
Jun 3, 2004
Messages
144
Location
Belgium
Programming Experience
5-10
AxInterop.MSChart20Lib is NOT a vs.net library nor a .Net framework library so reinstalling .net won't help you a bit. All AxInterop dll's are Com-objects which are imported into a .net solution. By the name MSCHART I'm guessing it's an MS office dll. Did you uninstall this recently?

when you expand the node references there should be a name (or 2) with an exclamation mark. You can solve this problem by adding the reference again,. Since this is a Com Object change the TAb to COM instead of .Net and search there. if that doesn't work then use browse to manually browse to the dll.
 
Top Bottom