New database table not showing in designer

ppirates

Member
Joined
Jul 19, 2006
Messages
12
Programming Experience
10+
I have added a new table to my access database which sits outside my VB 2005 project.

When I go back into visual studio 2005, I can't see the new table in the datasource designer. I have tried to add it to the designer, but even when I add it manually, it isn't working.

To give you a bit of background...

I have a database that the data is updated in, in the bin/release folder on my pc. I also have another database that the designer seems to use, but the data is never updated in when I do testing. I presume this database is just used for design/layout purposes.

If I bring in a new datasource (abc_Dataset1), I find that it shows the new table in a new datasource design window, but if I use that I will not have all the queries I am using on the tableadapters in the original datasource designer (abc_dataset) I have.

I am stuck at the moment, as I simply need to add the new record to my original datasource designer with an attached tableadapter. I didn't think this would be a problem, but it certainly is at the moment.

Any help would be much appreciated.

Cheers
Colin
 

zekeman

Well-known member
Joined
May 23, 2006
Messages
224
Programming Experience
10+
Backup project, delete the old control, and add it again if you can see
the new table.

I've acutally seen this work
 

ppirates

Member
Joined
Jul 19, 2006
Messages
12
Programming Experience
10+
Thanks for your help on this.

When you say delete the control, do you mean delete the dataset from the dataset designer?

If that is the case, then I am not too keen on doing that, as I have a number of SQL queries set up in the table adapters that I would lose.

Cheers
Colin
 
Top Bottom