Question Problem with .Net Framework install, please help

razz

Well-known member
Joined
Oct 11, 2008
Messages
67
Programming Experience
Beginner
I created a program using Microsoft Visual Basic 2008 Express Edition. I installed the program on my wife's PC and the following error was displayed when I tried to run the program:
To run this program you first must install one of the following versions of .Net framework:v2.0.50727
My wife's PC has the following .Net Framework versions installed: 1.1, 1.1 Hot Fix and 2.0 Service Pack 2. So I would have thought that Windows Update would have listed the .Net Frameworks she does not have installed, but no .Net Framework updates were shown as part of Windows Update. I then went to download version 3 but an error occurred during installation. The error report stated the following:
[10/11/08,01:17:53] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
[10/11/08,01:18:08] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
[10/11/08,01:18:09] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.


I feel that I may have to unistall .Net Framework 2 from my wife's PC and then try to reinstall it plus install version 3 and then install version 3.5.
The BIG question is this:
In the event that something goes wrong and I cannot reinstall .Net Framework 2 (after I uninstall it), will this cause any problems with general PC performance? I fear a possible problem because installation of version 3 failed when I tried. Any ideas?

Also, I am not sure if I need to install version 2,3 & 3.5 in sequence or if I can go directly to version 3.5?

It is very scary when you are so green when it comes to any knowledge concerning .Net Framework and you have problems that you need to fix. Any help is greatly appreciated!
 

JohnH

VB.NET Forum Moderator
Staff member
Joined
Dec 17, 2005
Messages
15,603
Location
Norway
Programming Experience
10+
VB 2008 compiles for .Net 3.5 by default. To deploy use the ClickOnce system built in, found in project properties Publish tab. Here you can also click the Prereq button and make it create a setup that checks for and installs .Net.

If you have messed up the Framework installations reinstalling could possibly work, if not uninstall then reinstall might be needed.
 

razz

Well-known member
Joined
Oct 11, 2008
Messages
67
Programming Experience
Beginner
Problem solved! I had to uninstall .Net Framework 2 and then reinstall it. Now all works well. Thank you for your time.
 
Top Bottom