NuSOAP WS sending text/html rather than text/xml to vs.net

cptnwinky

Member
Joined
Dec 4, 2004
Messages
7
Programming Experience
1-3
As you can tell from the title I made a php webservice to be consumed by my vb.net app. I put the dynamic url to the wsdl file (http://www.civilissues.com/NewsBot/phpbb211.php?wsdl) but for some reason, my guess is at least, that vs.net is only recognizing everything up till the ?wsdl. I tried to change the property from static to dynamic with no effect. I even edited the reference.vb file to fix the string to add the ?wsdl to the end with no effect. Also, I am using the NuSOAP error handling for my one function thus far and if that were the error it should return a soap fault not text/html.

Has this happened to anyone else? Could someone else try and consume this webservice and see if it does the same for them? Just so you know the sessionstart function is innoperable and you can pass it any two string values and it will just return a string similiar to kasdjflkjsdflkjsf at the moment.

Any help is very much appreciated.

Thanks
 

cptnwinky

Member
Joined
Dec 4, 2004
Messages
7
Programming Experience
1-3
I got that last error worked out, turns out I forgot to put the http_raw_headers stuff at the bottom of my php ws.

However, now I get this new error that I have no clue how to fix...

An unhandled exception of type 'System.InvalidOperationException' occurred in system.xml.dll

Additional information: There is an error in XML document (1, 499).
 

michael12

New member
Joined
Apr 28, 2010
Messages
1
Programming Experience
Beginner
I got that last error worked out, turns out I forgot to put the http_raw_headers stuff at the bottom of my php ws.

However, now I get this new error that I have no clue how to fix...

An unhandled exception of type 'System.InvalidOperationException' occurred in system.xml.dll

Additional information: There is an error in XML document (1, 499).

Hi there,
How would you solve the System.InvalidOperationException error problem?
also tell me that, when i paste my threads there is an error system fetal error.what is the solution of this,please guide
 
Top Bottom