very small point of note.. in Juggalo's code, he called his ArrayList with the name "TextFileArray" - i generally consider that if a name contains a type (e.g. Array, ArrayList) then it should be of the type of the object. For Juggalo to give his ArrayList object a name of "TextFileArray" might suggest that it is an Array, not an ArrayList. As you said in your original post, youre looking to make maintenance more easy, and this also goes for code maintenance. Giving the arraylist a name that suggests it is an ArrayList would be a good step in making your code more maintainable
(It might not matter for this project, but it s a sensible coding practice to adopt. Try to write witha perspective that, if another programmer were to come to your code, would he be able to understand a) what a variable is for, and b) what a variable type is, just from the name? If not, strive so that he could
types may be inferred or stated. for example, you should be able to guess what these are for:
ConnectionIsEstablished
(boolean, indicating an established connection)
_strFileContents
(string, of the contents of a file)
i
(used as a temporary integer, scope of a few lines max)
UnsupportedTranslationLanguageException
(error object thrown when a source language cannot be translated)
FailureCounter
(integer or numerical type counting failures)
EnumeratorForList(List l)
(method that should provide an enumerator for the specified list)
I doubt these exist anywhere in the framework.. just a few examples pulled out of my head and of course open to interpretation and different coding styles/standards in use.. but generally the way to go
