Toolbox missing ASP.NET controls

RTQ

New member
Joined
May 5, 2009
Messages
1
Programming Experience
10+
I recently installed Visual Studio 2008 Standard Edition on my Vista. However, for web sites and applications, the ASP.NET controls do not appear in the toolbox. While setting the toolbox to “show all” displays the Standard tab, it’s empty. I can manually type in the tag of an ASP control (e.g., <asp:Textbox…>, and the control appears to work fine.

Also, a series of messages appear in the output panel after VS starts up. An examples follows:

The Microsoft.Data.Entity.Design.Package.MicrosoftDataEntityDesignBootstrapPackage, Microsoft.Data.Entity.Design.Package, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a ({7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB}) did not load because of previous errors. For assistance, contact the package vendor. To attempt to load this package again, type 'devenv /resetskippkgs' at the command prompt.

In addition to several attempts at uninstalling/reinstalling VS 2008 and the .Net Framework (3.5/sp1), I deleted the *.tbd files in my \local\Microsoft\VisualStudio\9.0 folder, and tried resetting the toolbox. If I try to choose an item to add to the toolbox (e.g., the gridview control), Visual Studio crashes. I’ve also tried devenv/resetskippkgs from the command prompt.

Any suggestions would be appreciated.
 
Top Bottom