Error when configuring a dataadapter

chime

Member
Joined
Jul 12, 2005
Messages
22
Location
wexford, Ireland
Programming Experience
3-5
Hi

I get the following error when I try to configure my dataadapter

I have tested the connections in the server explorer and they work

"DRIVER={MySQL ODBC 3.51 Driver};SERVER=localhost;DATABASE=myDatabase;USER=myUsername;PASSWORD=myPassword;OPTION=3;"




I am new at this so its probably something obvious
 

MESDM

New member
Joined
Mar 14, 2005
Messages
3
Programming Experience
3-5
I take it your using Visual Studio..

Try using the wizard to make the connection then copy the code it produces.
 

kulrom

Well-known member
Joined
May 10, 2005
Messages
2,854
Location
Republic of Macedonia
Programming Experience
10+
Evidently you are trying to establish an ODBC connection but as Paszt noted you haven't included the Exception/Error message ... btw have you checked that certain ODBC connection is existing on your machine? Waiting for your feedback :)

Cheers ;)

added: Also be sure that you are entering the right UID and PWD as when you first install MySQL, it creates a " root " user account (in the sys datbase's user table) with a blank password.
 
Last edited:

chime

Member
Joined
Jul 12, 2005
Messages
22
Location
wexford, Ireland
Programming Experience
3-5
Hi

It seems to be working again after I restarted the pc.
The connections were correct as I was able to see the tables in server explorer

I have attached the error message
(I mustent have uploaded the file previously)

Thanks
 

Attachments

  • error.doc
    35.5 KB · Views: 32
Top Bottom