Recent content by Simon1203

  1. S

    error while trying to insert data into SQL database

    Have tried this and the inteli sense underligns it and gives the message "PupilAddressDetails" is not a member of system.data.dataset. I'm using VS2003 so could this be the problem? (I'm downloading VS2005 at the moment but it's gonna take a while) Given this a go and below is what I got for the...
  2. S

    error while trying to insert data into SQL database

    hehe I'm not offended. In fact thank you very much for typing all that advice out, it's really appreciated :D and it's certainly given me a lot to think on. This project is a mamouth one and I haven't done any program since the mid 90's (C++) so learning VB.Net is a big thing for me and any...
  3. S

    error while trying to insert data into SQL database

    mmm I'm sure that I have because an identical set of code and functions for another part of the app works fine and this is the way I have been taught to insert data into the SQL database whilst keeping the front end blissfully unaware of the logic required to enter the data into the database...
  4. S

    error while trying to insert data into SQL database

    Thanks for the advice. I re-ran the app and when it hit the error I hovered over each variable to see what each contained. The variable that said it had nothing was the objDataRow. The objAddressData object does contain the PupilAddressDetails dataset so I'm a bit confused as to why this is set...
  5. S

    error while trying to insert data into SQL database

    Thanks for the reply. I believe that I have initialised the objAddressData but I may be wrong. Below is the Variable declarations for the Form and also the bussiness logic and Data Access code from 2 classes which is being called: Variable Declarations: Private intIndex As Integer Public...
  6. S

    error while trying to insert data into SQL database

    Hi all I am creating a windows app which interacts with a SQL database so data is contantly being called and written to the database. I have a maddening problem with this set of code and it is driving me up the wall! When I run my build and call the function below I get an Object reference...
Top Bottom